Question
========
The primary VIOS has the reserve policy set to no_reserve, and the secondary VIOS has it set to single path. The LUN is exported as a backing device. How do I change reserve policy to no_reserve on the secondary VIOS?

This document applies to VIOS 2.x

Answer
======
In the following example, the VIO (AIX) Client has virtual SCSI disks, hdisk11 and hdisk12 that are part of a volume group called clientvg. Their corresponding backing devices (SAN disks) are known as hdisk22 and hdisk23 on the second VIOS (VIOS2).

On the VIO CLIENT, as root:
————————–
1. Ensure you have an up-to-date backup of clientvg BEFORE you do anything else.

2. Unmount all filesystems on clientvg and deactivate the volume group:

# unmount /fsname
# varyoffvg clientvg

3. Put target hdisk (for this example hdisk11 & 12) in a “Defined” state.

# rmdev -l hdisk11
(repeat for hdisk12)

NOTE: Another option is power off the VIO Client.

On VIOS2 (where you need to change reserve policy to “no_reserve”) as padmin user:
———————————————————————————
4. Remove the VTD for target hdisk (in this example hdisk22 & 23).

$ rmvdev -vtd

To find out VTDnames run

$ lsmap -vadapter vhost0
(where vhost0 is the SCSI Server Adapter hdisk22 & 23 are exported through)
=>look for VTD line associated with backing device hdisk22 & 23

5. Change the reserve policy.

$ lsdev -dev hdisk22 -attr =>reserve_policy = single_path is expected
$ chdev -dev hdisk22 -attr reserve_policy=no_reserve
$ lsdev -dev hdisk22 -attr =>reserve_policy should now be set to no_reserve
(repeat this for hdisk23)

6. Recreate VTDs for hdisk22 & 23

$ mkvdev -vdev hdisk22 -vadapter vhost0 -dev
(repeat for hdisk23)

NOTE: Another option is to put the VTD(s) in a “Defined” state before changing the reserve policy, and then make “Available” after the change has been made, instead or removing and recreating.
ON VIO CLIENT, as root:
———————-
7. At this point, bring hdisk11 & 12 back to “Available” state

# cfgmgr
# lsdev -Cc disk =>hdisk11 & 12 should be back available
8. Reactivate the volume group and remount the filesystem(s).

# varyonvg clientvg
# mount /fsname

(or activate the VIO Client if it was shutdown)